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Product Overview
Presto Arranger lets you play, modify, and create music using your PC, even without musical training or special 
equipment.



Presto Arranger Controls
Click on the picture below for more information.

Note: Some aspects of the user interface, including the title bars and minimize buttons, e.g., differ slighlty 
between Windows 3.1 and Windows 95.



Title Bar:    Displays the title of the currently loaded MIDI file, if any.



Menu Bar:    Provides Presto Arranger functions through pull-down menus.



Toolbar:    Offers convenient push-button access to many functions also available through the menus.    You can 
toggle display of the Toolbar on and off under the View menu.



 New File:    Clears the currently loaded file



 Open File:    Loads an existing MIDI file from disk



 Save File:    Saves the current recording in a MIDI file



 Undo:    Cancels the previous editing operation



 Cut:    Deletes the selected MIDI measures



 Copy:    Copies the selected measures to the clipboard



 Paste:    Copies Presto Arranger MIDI from the clipboard



 Mixer:    Launches the mixer application, if available



 Help:    Displays the Online User Guide



Button Bar:    Offers Record, Rewind, Play, and Stop buttons, as well as Time Signature and Tempo controls.



 Record:    Starts recording your keyboard input



 Rewind:    Sets the current position to the start of the song



 Play:    Starts playing at the current position



 Stop:    Stops playing



Time Signature : Displays and lets you set the time signature of the current song



Tempo : Displays and lets you set the speed of the song, in beats per minute



Position Indicator:    Vertical bars indicate the current position, where Presto Arranger starts playing when the Play 
button is pressed.    To set the current position, click at the desired location in the row of numbers indicating the 
songs measures (bars).    Here, current position is the start of the sixth measure.



Track View:    Displays MIDI songs in a convenient way, separating each part that a musician would play into its 
own horizontal track.    Most editing functions occur in Track View.    You can open more than one MIDI song at a 
time, each with its own Track View.



Keyboard View:    Shows an on-screen keyboard that plays along with songs and which you can play using your 
mouse or the top two rows of your PC keyboard (excluding the function key row).



Selecting Views
Each song you load into Presto Arranger is displayed in its own Track View window.    Each of these windows, along
with the Keyboard View window, can be moved and sized independently, letting you arrange the on-screen display 
to your liking.    To have Presto Arranger arrange the windows for you, select Tile or Cascade from the Windows 
menu.    You can also select Auto Tile from the Options menu, to have Presto Arranger tile all open windows 
whenever you load a song.



Loading and Playing a MIDI Music File
To have Presto Arranger play existing MIDI music files:

1. Select Open from the File menu, or click on the Open File button.

2. In the Open box, navigate among the directories to locate and highlight the .MID or .RMI file you want to 
play.    Click on the OK button.    Note that the Title Bar will now show the name of the MIDI file.

3. If you have more than one MIDI song open, click on the Track View window of the song you wish to play, 
to make it active.

4. Press the Play button.

You should hear your song playing and see the double vertical bar in the Track View window moving to the right, 
indicating the current position in the music file.    If you have clicked on the Kbd cell of a track containing music, 
the on-screen keyboard in the Keyboard View will play along with the music.



Controlling Song Position
When you click on the Play button, Presto Arranger starts playing from the current position.    Current position is 
shown by the double vertical bar in the Track View window.    To control current position:

Click on the Rewind button to set the current position to the beginning of the song, or

Click on a measure indicator in the Track View header to make the start of that measure the current 
position



The "Player Piano" in Keyboard View
When Presto Arranger plays a MIDI file, its on-screen keys play along with the music in the manner of an old 
fashioned player piano.    The keyboard plays the notes of the MIDI track you select by clicking your mouse in the 
Kbd column of the track.

You can specify the number of keys to show on screen with the Keyboard Octaves item under the Options menu.



Selecting a MIDI Output Device
Depending on your audio hardware, you may be able to choose among multiple MIDI output devices.    You choose 
the MIDI output device from the Options menu.    Typical choices could include:

FM (also called Basic, OPL2, or OPL3) Synthesis:    The most basic method of generating MIDI music, FM 
Synthesis uses sophisticated equations to simulate each instrument and its notes.

Wavetable Synthesis:    Generally found on more expensive sound cards, Wavetable Synthesis generates music by 
playing digitally recorded samples of musical instruments for each MIDI note.    Wavetable Synthesis produces 
higher quality music than FM.

Control Panel MIDI Settings, or MIDI Mapper:    Uses the MIDI output device specified by the Windows Control
Panel.



An Absolutely Minimal Music Overview
Presto Arranger displays each MIDI song in tracks.    Usually, each track represents the part a single musician plays 
in the song.    The music in each track is shown as a series of small rectangles, each a measure (or bar) of music.    
Each measure is a few beats long.    Depending on the song, this is often about a second of music.

For each track, you can change the instrument, how loudly it plays (its velocity), how high or low it sounds (its 
pitch), and where it plays between your speakers (its left/right "pan" position).    You can also use cut and paste 
editing to alter the track or entire song.



Changing Instruments
To change the instrument in a track:

1. Open (or record) a MIDI file.

2. In the Track View window, click on the name of the instrument you want to change.    A list of available 
instruments will appear.

3. Select the instrument you wish from the instrument list.

4. Click on the OK button to return to the main screen with the instrument change in effect.



Changing An Instrument Left/Right Pan Position
To change left to right position between your speakers at which an instrument plays (if your audio hardware 
supports MIDI panning):

1. Click on the Pan cell in the track containing the instrument

2. In the resulting window, specify a number from 0 to 127; 0 indicates that the instrument should play only 
from the left speaker, while 127 dictates that it should play only from the right speaker.    For example, 31 
would have three quarters of the output come from the left speaker and one quarter from the right speaker, 
positioning the instrument one quarter of the way from the left speaker to the right speaker.

3. Click on the OK button to accept the position



Changing Pitch and Volume
To change the pitch or volume for selected measures:

1. Use the mouse to select the measures to modify.    (Do this by clicking on the first measure you want and 
holding down the mouse button while dragging the mouse to select more measures.)

2. Select Adjust Volume or Adjust Pitch from the Edit menu

3. In the resulting adjustment box, enter a number from -127 to +127 to add to the current volume or pitch.    
The resulting addition must produce a number from 0 to 127.

More About Pitch:    The pitch number is displayed on each key in the Keyboard View.    For example, Middle C 
has pitch number 60.    To change the pitch of the selected notes, enter a positive or negative number to add to their 
pitch.    To increase the pitch of the notes by one octave, enter 12.    To decrease the pitch by one octave, enter -12.



Editing Songs with Cut and Paste
You can cut, copy, and paste measures of music using familiar Windows techniques.    After you make an edit, you 
can use the Undo menu item or button to cancel the effect of the most recent edit.

Selecting Measures

To select the measures you wish to modify or copy:

1. Left click your mouse on a measure

2. Hold down the mouse button while moving the mouse cursor over additional measures.    Each selected 
measure changes color.

3. When you have selected what you want, release the mouse button.

4. To select the entire song for editing, use the Select All menu item from the Edit menu.

Cutting or Copying Measures

After you have selected the measures you want:

To delete them, click on the Cut button or select Cut from the Edit menu.    When you use the Edit menu, you can 
choose to leave an empty space where the measures came from (Cut - Leave Hole) or to move all measures that 
come afterwards leftwards to prevent a gap in the music (Cut - Delete Hole).

To copy them, click on the Copy button or select Copy from the Edit menu.

Pasting Measures

To paste measures you have previously cut or copied:

1. Click on the location where you want to place the measures.    You can paste measures anywhere, even into 
a track or MIDI song other than the one from which you cut or copied them.

2. To place one copy of the measures into the desired location, click on the Paste button or select Paste from 
the Edit menu.    To place multiple copies instead (for a repeating chorus, e.g.), select Paste Repeatedly from
the Edit menu.    Presto Arranger will ask you how many copies to paste.



Changing the Tempo of a Song
To change the speed at which a song plays, use the up and down arrows to adjust the Tempo on the Button Bar.



Your Choice of Keyboards
You can play and record music using any of three input devices:

Your own PC keyboard.    The top two rows (excluding the function key row, if you have one) correspond to the 
white and black key rows on the on-screen keyboard in Keyboard View.

Your mouse.    Clicking your mouse on the on-screen keyboard plays the indicated notes.    A left mouse button click
is a simple key press and release, while a right mouse button click sustains the keyboard note until the key is clicked 
on again.

An external MIDI keyboard attached to your PC MIDI input connector



Recording Music
To make your own music, regardless of the MIDI input device:

1. To add your music to an existing song, load the song by clicking on the Open File button or selecting Open 
from the File menu.    To record a completely new song, select New from the File menu or click on the New
File button.

2. Select the track to which you want to add your music by clicking on the Kbd cell in the track.    A red dot 
should appear there.

3. If the track does not already have a Channel Number, click on the Ch cell for that track and select an 
unused channel number (that is, a channel number not already used by a different track).

4. Click on the Instrument name in the track, and select the instrument you wish to play.

5. Click on the Measure Indicator in the Track View header to specify at which measure to begin recording.

6. Click on the Record button in the Button Bar, and begin playing.    If you are recording into an existing 
MIDI song, you will hear the song play while you perform.

7. When finished recording, press the Stop button.    Play the song with your music included, or edit the song 
if    you like.    If not satisfied, just delete all or part of what you played, and try again.

8. To add a comment to a track, click on the Track Name cell in the track and type your comments into the 
space that is offered.

9. When done, click on the Save button or select Save from the File menu to save the song.



Setting the Time Signature of a Song
To specify the Time Signature of a new song you are recording, select the Set Time Signature button from the Button
Bar.




